Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] CDM7160 - PPM Value Oscillation
Hi Guys,

It seems like the CDM7160 module is quite sensitive to noise from the power supply. I tested with several USB Chargers that i have and with all of them there is an oscillation of +/- 100 ppm in the output values. It also seems that some units are more affected from this than others.

On the other hand it works quite stable when powered from the Laptop or from a USB Battery.

I have contacted the manufacturer for some advice about this last week, but there is still no reply from them.

Unfortunately with the hobby-grage oscilloscope i have it is not possible to see further details, so next week i will go to a laboratory to analyze in detail what is the difference between the 5V from the Charger and the 5V from the Laptop. 

Most probably the solution will be some hardware filter that connects between the power supply and the device or between the sensors power supply and the base-board. Once i've figured it out and make it i will send it to all of you free of charge.

Regards, Vladimir
Wow, great to see you are supporting your product to this extend. I'm curious what you will find in the lab!
Yeah, i went there, we tried with various oscilloscopes, spectrum analyzers an so on, yet we could not find anything.
So i continued testing out various stuff and eventually i found what the issue is, though i have no idea yet how to solve it.

It seems like the sensor is quite sensitive to the ground connection, and in case i connect the ground of my board to the Earth from a power outlet, or to the ground from an USB Port on a laptop - it works quite fine, once i disconnect it - the fluctuations start.

Now that this is easily reproducible i will ask some experts to give advice specifically on this. I hope there is some electronic know-how bit that i am missing

Regards, Vladimir
Hi Guys,

After some frustrating 10 days, while spending most of my time searching for the root of the problem, it turned out to be caused by some Electromagnetic Interferce.
Apparently the Specsheet of the sensor incorrectly warned that it is only ESD un-protected, but they didn't mention about EMI.

I will write a bit more once i've done some more testing with more sensors, but for now - one of them that kept oscillating quite a bit, got silenced once i taped it all with electrical tape and then wrapped it with some aluminium foil and connected it with an aligator clip to ground.

Yet - it somehow depends where exactly the aluminium foil is.
Also apparently only some devices are vulnerable to EMI, while others are not.. i haven't yet succeeded in getting a consistent relation between charger, cable, assembly or place. Sometimes just switching two ports on the same charger causes EMI to start.

It is quite frustrating searching for the issue, as in the moment it gets to some reproducible results - i move something apparently unrelated and the issue stops
i will send you more details over the weekend

Regards, Vladimir
Here are some more details, how the output of the CDM7160 changes once a simple EMI filter is applied by insulating the sensor with electrical tape, wrapping it with some aluminium foil and connecting it via some alligator clip to ground. It is a pity the manufacturer (FIGARO) of this sensor released such an immature product... but - that's life. Luckily it is fixable.

The problem with aluminium foil is that you cannot solder it easy and connect it to ground. I have also somewhere some roll of copper foil, but i couldn't find it yet. In the next couple of days i will check what is the best way to patch it, w/o having to send them back to me. It will be something like a patch of adhesive copper foil with a soldered connector that you can easily wrap around the sensor. Of course there will be the possibility to send me back the device for repair (free for you of course) if you do not want to fiddle with this

And here are the results (Note - those are the raw results, taken each 30 seconds.)
This one was oscillating pretty hard when i put it on a special place on my desk. @~17.20 i applied the fix, then few minutes later tried temporarily disconnecting ground to see if it necessary - it was. Below is another one

[Image: cmd7160_EMIshield.png]

This one was oscillating +/- 50 ppm. Initially this is what i had discovered about this sensor. While not ideal i decided that if this is the raw output, other sensors anyway apply some smoothing, so maybe this is it. In fact after applying smoothing those fluctuations got more or less hidden.
Yet -after applying the fix to this sensor as well - the raw output's fluctuations went down to +/-5 ppm. Given the fact that the resolution of the CM1102 is 10 ppm, i believe this is in the range of acceptable error for those sensors.

[Image: CDM7160_EMIFilter2.png]
I'm not convinced that the power supply/EMI/whatever sensitivity is specific to the CDM7160. With mine it all seems rock solid on some power supplies but with others I get all sorts of oddities like:

2016-10-15T21:08:19 /?temp=22.58&hum=51.40&co2=779.00
2016-10-15T21:09:21 /?temp=-141.44&hum=100.00&co2=776.50
2016-10-15T21:10:23 /?temp=22.60&hum=51.44&co2=780.50
2016-10-15T21:11:25 /?temp=22.60&hum=0.00&co2=781.00
2016-10-15T21:12:28 /?temp=22.60&hum=51.37&co2=791.00

With one supply configuration the device just stops after a while, typically 1.5 hours but sometimes quicker. With another I usually get continuous %CO2% outputs. I'd suggest some fairly extensive testing before you roll out a fix. If there's anything you'd like me to try on mine then please ask.
hmmm this is strange, apparently the temperature sensor is affected by something else Smile
They are all connected via i2c, and while for the CO2 sensor i implemented quite some testing to filter out bad results, for the temerature sensors i haven't i will look into this as well

What would help is:
1. with the power supply with the %CO2% - can you measure the output voltage. Seems like the sensor does not like voltages outside the USB spec (>5.25), and in fact i have at least one USB battery that outputs 5.40, and my original Samsung S4 charger gives ~5.28-5.35
2. if you have a scope - you can also try to measure the power quality of the bad power supplies, another one that i had (1$ chineese one) had an almost triangular output which jumps between 4.7 and 5.2 V

So, the subject says solved, but what is the solution?

I have tried a lot of different power supplies but in the end on all of them the sensor stops working. Looks like the best way is connecting the sensor to my pc, but I don't have that running al the time...

That most power supplies don't keep the USB spec wasn't news for me, mostly the device you connect to it handles this.
hmmm this is a different problem
how does it stop - simply no data sent to the server? or data is garbage?
Data stops sending. At first maybe one of the sensors but in the end all of them stop.

Forum Jump:

Users browsing this thread: 1 Guest(s)