vThings Forums
[SOLVED] v.Air - CO2 Monitor not recognised (CM1106) - Printable Version

+- vThings Forums (http://forum.vair-monitor.com)
+-- Forum: vThings (http://forum.vair-monitor.com/forumdisplay.php?fid=1)
+--- Forum: vAir Monitor (CO2, Dust, Tempereature, etc..) (http://forum.vair-monitor.com/forumdisplay.php?fid=2)
+--- Thread: [SOLVED] v.Air - CO2 Monitor not recognised (CM1106) (/showthread.php?tid=54)

Pages: 1 2


[SOLVED] v.Air - CO2 Monitor not recognised (CM1106) - vaanja - 01-25-2017

Hi Vladimir,
after latest firmware update my v.Air CO2 monitor stopped working.
It looks like firmware is not able to recognize sensor.
I've done several factory resets, but no change.
My sensor details:

Chip ID1138269
Flash Chip ID1458400
IDE Flash Size4194304 bytes
Real Flash Size4194304 bytes
Soft AP IP192.168.4.1
Soft AP MAC5E:CF:7F:11:5E:5D
Station MAC5C:CF:7F:11:5E:5D

How can I solve this situation? Is latest firmware for all your products?



Code:

Code:
Searching for v.Air Trying : COM3

Trying : COM4

Trying : COM5

Trying : COM6

Trying : COM7

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . Searching for v.Air Trying : COM3

Trying : COM4

Trying : COM5

Trying : COM6

Trying : COM7

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . Searching for v.Air Trying : COM3

Trying : COM4

Trying : COM5

Trying : COM6

Trying : COM7

.  . [^E]
[@ÑVäèLJŒ]
[`N]
[:Kì]
. [vESPrino v1.16 build20170122]

vESPrino found on : COM5
[]
[No I2C Devices found
crc40prop_list
prop_list
---vESPrinoCFG_start---
stored.i2c=0xFFFFFFFFFFFFFFFF
cubic.co2.missing=missing
ds18b20.port=missing
has.sensors=none
---vESPrinoCFG_end---
ready >]
[crc61nop 0
nop 0
ready >]
[Expected Sensors: none found:
if the device configuration is changed, trigger a Factory Reset to update sensors]
[Device initialized.

---Sending data---
CustomHTTPDest::process
CustomHTTP : 32ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 1
GMTTIME    : 4294967295
RSSI    : 31
SerialDump : 125ms
MQTTDest::process
MQTT : 69ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms
fupd
ready >]
[IP address: 192.168.1.87 in 3404 ms
GOT IP]
[wss_start


WebSockets Server started on wss://192.168.1.87:8266
Open http://config.vair-monitor.com to configure device online
ready >]
[[0] Disconnected!
nop 300
ready >]
[[1] Disconnected!
nop 300
ready >]
[[0] Connected from 192.168.1.61 url: /
info

vESPrino v1.16 build20170122
IP address: 192.168.1.87
Chip ID: 115E5D
ready >]
[nop 0
ready >]
[info

vESPrino v1.16 build20170122
IP address: 192.168.1.87
Chip ID: 115E5D
ready >
prop_list
---vESPrinoCFG_start---
stored.i2c=0xFFFFFFFFFFFFFFFF
cubic.co2.missing=missing
ds18b20.port=missing
has.sensors=none
---vESPrinoCFG_end---
ready >]
[nop 0
ready >]
[---Sending data---
CustomHTTPDest::process
CustomHTTP : 31ms
SerialDumpDest::process
IP    : 192.168.1.87
CHIPID    : 115E5D
RUNTIME    : 121
GMTTIME    : 66060001
RSSI    : -44
SerialDump : 131ms
MQTTDest::process]
[MQTT : 70ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms]
[---Sending data---
CustomHTTPDest::process
CustomHTTP : 30ms
SerialDumpDest::process
IP    : 192.168.1.87
CHIPID    : 115E5D
RUNTIME    : 242
GMTTIME    : 66180262
RSSI    : -45
SerialDump : 131ms
MQTTDest::process]
[MQTT : 69ms
RFDest::process
RFX10 : 1ms
Blynk : 0ms]



RE: v.Air - CO2 Monitor not recognised - admin - 01-25-2017

hmmm... can yo uconnect it via usb and tigger factory reset
to get to output
i will post later the link to the old fw if you want to rever to it while i fix this


RE: v.Air - CO2 Monitor not recognised (CM1106) - admin - 01-25-2017

i updated this thread
http://forum.vair-monitor.com/showthread.php?tid=18
with the link to the latest stable firmware


RE: v.Air - CO2 Monitor not recognised (CM1106) - vaanja - 01-26-2017

Hi Vladimir,
I tried several firmwares (20170103, 20161217, 20161215) followed by firmware reset, but still no luck.
Code:
Searching for v.Air Trying : COM3

Trying : COM4

Trying : COM5

Trying : COM6

Trying : COM7

.  . [^EPÑVø]
[dÅØØ]
[YÀh]
[üø]
. […]
[Heap Heap at start: 36432]
. [No I2C Devices found

vESPrino]

vESPrino found on : COM5
[v1.16 build20161006]
[IP address: 0.0.0.0
Chip ID: 115E5D]
[ready >
Waiting for auto-connect]
[OK
---vESPrinoCFG_start---
stored.i2c=0xFFFFFFFFFFFFFFFF
cubic.co2.missing=missing
ds18b20.port=missing
has.sensors=none
wifi.ssid=[hidden]
wifi.p1=[hidden]
tsKey=XXX
custom_url_arr0=#http://api.thingspeak.com/update?key=XXX&field1=%CO2%
isMigrated=1
rf.CO2=136
rf.PM25=137
rf.PM10=138
rf.TEMP=140
rf.HUM=141
rf.PRES=142
rf.GEN=143
send.interval=120
---vESPrinoCFG_end---
ready >]
[OK
ready >]
[.]
[.]
[.]
[No I2C devices found]
[No I2C devices found


--- Setup PLUGINS ---
Setup plugin: Neopixel
Setup plugin: TimerManager

--- Setup SENSORS ---
Setup sensor: TEST
Setup sensor: CO2]
[Setup sensor: SI7021]
[Setup sensor: BME280]
[Setup sensor: PM2005]
[Setup sensor: CDM7160]
[--- Setup DESTINATIONS ---
Setup Destination: CustomHTTP
Setup Destination: SerialDump
Setup Destination: MQTT
Setup Destination: RFX10
Heap At setup end: 33376
Waiting for WiFi]
[.]
[.]
[.]
[IP address: 192.168.1.87 in 13808 ms
GOT IP]
[fg: 20161217, fc: 0, bn:20161006
Will update from: http://anker-bg.com/vlast3k/vesprino/firmware20161217.bin]
[V8¸àL)⌰_]
[ü]
[…]
[Heap Heap at start: 35392

vESPrino v1.16 build20161217
IP address: 0.0.0.0
Chip ID: 115E5D
ready >
Waiting for auto-connect]
[No I2C Devices found]
[.]
[.]
[.

--- Setup PLUGINS ---
Neopixel
fupd]
[fg: 20161217, fc: 0, bn:20161217
ready >DweetIO
WebServer
PowerManager
GPIO
Servo
Annemometer
TimerManager

--- Setup SENSORS ---
TEST
CO2
SI7021
BME280
BMP085
PM2005
CDM7160
TSL2561
BH1750
APDS9960

--- Setup DESTINATIONS ---
CustomHTTP
SerialDump
MQTT
RFX10
Blynk]
[Heap At setup end: 32448
IP address: 192.168.1.87 in 14449 ms
GOT IP
sendNowCond

--- DestHanlder: sendValue --- 1
CustomHTTPDest::process
SerialDumpDest::process
IP    : 192.168.1.87
CHIPID    : 115E5D
RUNTIME    : 14
MQTTDest::process
RFDest::process
ready >]
[sendNowCond

--- DestHanlder: sendValue --- 0
ready >]
[info

vESPrino v1.16 build20161217
IP address: 192.168.1.87
Chip ID: 115E5D
ready >sendNowCond

--- DestHanlder: sendValue --- 0
ready >]
[scani2cbus
ERROR: Command not recognized
ready >]
[scani2c
Scanning SDA:SCA = D1:D5]
[No I2C devices found

Scanning SDA:SCA = D1:D7]
[No I2C devices found

Scanning SDA:SCA = D1:D6]
[No I2C devices found

Scanning SDA:SCA = D5:D1]
[No I2C devices found

Scanning SDA:SCA = D5:D7]
[No I2C devices found

Scanning SDA:SCA = D5:D6]
[No I2C devices found

Scanning SDA:SCA = D7:D1]
[No I2C devices found

Scanning SDA:SCA = D7:D5]
[No I2C devices found

Scanning SDA:SCA = D7:D6]
[No I2C devices found

Scanning SDA:SCA = D6:D1]
[No I2C devices found

Scanning SDA:SCA = D6:D5]
[No I2C devices found

Scanning SDA:SCA = D6:D7]
[No I2C devices found

ready >]

There is no I2C device detected. I already re-solder all joints. What else I can try? Is there any way to check if CM1106 is alive?
Many thanks in advance.
Ivan


RE: v.Air - CO2 Monitor not recognised (CM1106) - admin - 01-28-2017

sorry, just now i saw that you replied, seems sometimes i do not get updates, or maybe i miss them

i actually missed a point about the updates - it is that regardless of which firmware you update to the latest one that i pushed to all devices and this is build20161217, and this one considers the
cubic.co2.missing=missing
property, and only if it is "present" then it will try to search for the sensor
so you can turn it on with
prop_set "cubic.co2.missing","present"
or do a factory reset


RE: v.Air - CO2 Monitor not recognised (CM1106) - vaanja - 01-28-2017

Hi Vladimir,
I had this sensor in the shelf several weeks and few days ago I decided to test somenthing with it.
It was working well until now.
I'm not sure what happened, but I believe since it was automatically updated to build20161217 it is not recognising CM1106.
Even I do factory reset several times, there is no sensor recognised (prop_set "cubic.co2.missing","present" does not help).
Here is my log:
Code:
Searching for v.Air Trying : COM3

Trying : COM4

Trying : COM5

Trying : COM6

Trying : COM7

.  .  . [´HlðJâ$]
[>ÁØ]
[@xà]
[i]
[ÿ]
. [DEBUG is: 1]
.  .  . [vESPrino v1.16 build20170122]

vESPrino found on : COM5
[IP address: 0.0.0.0
Chip ID: 115E5D]
[No I2C Devices found]
[--- Setup PLUGINS ---
WifiStuff
Scheduling command: crc40prop_list
Scheduling command: @nop
crc40prop_list
Scheduling command: prop_list
prop_list
---vESPrinoCFG_start---
stored.i2c=0xFFFFFFFFFFFFFFFF
cubic.co2.missing=missing
ds18b20.port=missing
has.sensors=none
isMigrated=1
rf.CO2=136
rf.PM25=137
rf.PM10=138
rf.TEMP=140
rf.HUM=141
rf.PRES=142
rf.GEN=143
wifi.ssid=[hidden]
wifi.p1=[hidden]
tsKey=XXXXXXXXX
send.interval=60
custom_url_arr0=#http://api.thingspeak.com/update?key=XXXXXXX&field1=%CO2%
debug=true
---vESPrinoCFG_end---
ready >
WebSocketServer]
[]
[Scheduling command: crc61nop 0
Scheduling command: @nop
crc61nop 0
Scheduling command: nop 0
nop 0
ready >
WebServer]
[PowerManager
GPIO]
[Servo
Annemometer]
[DestinationManager
TimerManager

--- Setup SENSORS ---]
[CM110x : 0
TEST : 0
SI7021 : 0
BME280 : 0
BMP085 : 0
PM2005 : 0
CDM7160 : 0
DS18B20 : 0
TSL2561 : 0
BH1750 : 0
APDS9960 : 0
Expected Sensors: none found:
if the device configuration is changed, trigger a Factory Reset to update sensors

--- Setup DESTINATIONS ---
CustomHTTP
SerialDump
MQTT
RFX10
Blynk]
[Heap At setup end: 33680
Device initialized.
Scheduling command: @sendNow
Check time from google

---Sending data---
CustomHTTPDest::process
Response Code: -13]
[CustomHTTP : 89ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 6
GMTTIME    : 43856607
RSSI    : 31
SerialDump : 123ms
MQTTDest::process]
[MQTT : 84ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms]
[Heap : 33536
Scheduling command: fupd
fupd
ready >]
[Scheduling command: crc63prop_set "cubic.co2.missing","present"
Scheduling command: @nop
crc63prop_set "cubic.co2.missing","present"
Scheduling command: prop_set "cubic.co2.missing","present"
prop_set "cubic.co2.missing","present"]
[ready >]
[Scheduling command: @sendNow

---Sending data---
CustomHTTPDest::process
Response Code: -13]
[CustomHTTP : 88ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 68
GMTTIME    : 43919321
RSSI    : 31
SerialDump : 124ms
MQTTDest::process]
[MQTT : 85ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms]
[Heap : 33536]
[Scheduling command: crc71nop
Scheduling command: @nop
crc71nop
Scheduling command: nop
ready >]
[Scheduling command: crc1Dcustom_url_clean
Scheduling command: @nop
crc1Dcustom_url_clean
Scheduling command: custom_url_clean
custom_url_clean]
[ready >]
[Scheduling command: crc16custom_url_add "0","#http://api.thingspeak.com/update?key=XXXXX&field1=%CO2%"
Scheduling command: @nop
crc16custom_url_add "0","#http://api.thingspeak.com/update?key=XXXX&field1=%CO2%"
Scheduling command: custom_url_add "0","#http://api.thingspeak.com/update?key=XXXX&field1=%CO2%"
custom_url_add "0","#http://api.thingspeak.com/update?key=XXXXX&field1=%CO2%"]
[ready >]
[Scheduling command: @sendNow

---Sending data---
CustomHTTPDest::process
Response Code: -13]
[CustomHTTP : 90ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 131
GMTTIME    : 43982011
RSSI    : 31
SerialDump : 125ms
MQTTDest::process]
[MQTT : 84ms
RFDest::process
RFX10 : 1ms
Blynk : 0ms]
[Heap : 33536]
[Scheduling command: crc74factory
Scheduling command: @nop
crc74factory
Scheduling command: factory
factory
Doing Factory Reset, and restarting...]
[SPIFFS configuration removed]
[wss_stop]
[R0°c(ªýì]
[vESPrino v1.16 build20170122
IP address: 0.0.0.0
Chip ID: 115E5D]
[No I2C Devices found
i2c bus storing: 0xFFFFFFFFFFFFFFFF]
[autoconfig]
[*WM: SET AP STA
*WM:
*WM: Configuring access point...
*WM: vAirMonitor_115E5D]
[*WM: AP IP address:
*WM: 192.168.4.1
*WM: HTTP server started
ready >]
[Device initialized.

---Sending data---
CustomHTTPDest::process
CustomHTTP : 34ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 9
GMTTIME    : 4294967295
RSSI    : 31
SerialDump : 125ms
MQTTDest::process]
[MQTT : 74ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms
fupd
ready >]
[crc52static_ip ,,,,,
static_ip ,,,,,]
[ready >]
[crc44wifi "SkToVaanja2012","XXXXX"
wifi "SkToVaanja2012","XXXXX"]
[Connecting to: "SkToVaanja2012", "XXXXX"]
[Waiting for WiFi]
[.]
[.]
[.]
[.]
[IP address: 192.168.1.87 in 27431 ms
GOT IP]
[ledcolor seqcgcgcgn]
[restart
wss_stop]
[/RÜÔ!Êàd:U]
[vESPrino v1.16 build20170122
IP address: 0.0.0.0
Chip ID: 115E5D]
[No I2C Devices found]
[Expected Sensors: none found:
if the device configuration is changed, trigger a Factory Reset to update sensors]
[Device initialized.

Waiting for WiFi]
[.]
[.]
[.]
[.]
[.]
[IP address: 192.168.1.87 in 6477 ms
GOT IP]
[]
[---Sending data---
CustomHTTPDest::process
CustomHTTP : 37ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 1
GMTTIME    : 44100001
RSSI    : -66
SerialDump : 124ms
MQTTDest::process]
[MQTT : 77ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms
wss_start


WebSockets Server started on wss://192.168.1.87:8266
Open http://config.vair-monitor.com to configure device online
ready >
fupd]
[fg: 20161217, fc: 0, bn:20170122
ready >]
[crc33!otah
otah
Will update from: http://anker-bg.com/vlast3k/vesprino/latest.bin
ledcolor red
ledbrg 80]
[.QÜ£!äüD:Uþ]
[ÿ]
[vESPrino v1.16 build20170122
IP address: 0.0.0.0
Chip ID: 115E5D]
[No I2C Devices found]
[Expected Sensors: none found:
if the device configuration is changed, trigger a Factory Reset to update sensors]
[Device initialized.

Waiting for WiFi]
[.]
[.]
[.]
[.]
[.]
[IP address: 192.168.1.87 in 14523 ms
GOT IP]
[]
[---Sending data---
CustomHTTPDest::process
CustomHTTP : 36ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 9
GMTTIME    : 44160001
RSSI    : -62
SerialDump : 124ms
MQTTDest::process]
[MQTT : 77ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms
wss_start


WebSockets Server started on wss://192.168.1.87:8266
Open http://config.vair-monitor.com to configure device online
ready >
fupd]
[fg: 20161217, fc: 0, bn:20170122
ready >]
[crc55!factory
factory
Doing Factory Reset, and restarting...]
[SPIFFS configuration removed]
[wss_stop]
[/SÜ£¹†ÿd:Uþ]
[vESPrino v1.16 build20170122
IP address: 0.0.0.0
Chip ID: 115E5D]
[No I2C Devices found
i2c bus storing: 0xFFFFFFFFFFFFFFFF]
[autoconfig]
[*WM: SET AP STA
*WM:
*WM: Configuring access point...
*WM: vAirMonitor_115E5D]
[*WM: AP IP address:
*WM: 192.168.4.1
*WM: HTTP server started
ready >]
[Device initialized.

---Sending data---
CustomHTTPDest::process
CustomHTTP : 35ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 9
GMTTIME    : 4294967295
RSSI    : 31
SerialDump : 125ms
MQTTDest::process]
[MQTT : 74ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms
fupd
ready >]
[crc0Einfo
info

vESPrino v1.16 build20170122
IP address: 0.0.0.0
Chip ID: 115E5D
ready >]
[crc52static_ip ,,,,,
static_ip ,,,,,]
[ready >]
[crc44wifi "SkToVaanja2012","XXXXX"
wifi "SkToVaanja2012","XXXXX"]
[Connecting to: "SkToVaanja2012", "XXXXX"]
[Waiting for WiFi]
[.]
[.]
[.]
[IP address: 192.168.1.87 in 78445 ms
GOT IP]
[ledcolor seqcgcgcgn]
[restart
wss_stop]
[R2° !Èþü˜]
[vESPrino v1.16 build20170122
IP address: 0.0.0.0
Chip ID: 115E5D]
[No I2C Devices found]
[Expected Sensors: none found:
if the device configuration is changed, trigger a Factory Reset to update sensors]
[Device initialized.

Waiting for WiFi]
[.]
[.]
[.]
[.]
[.]
[IP address: 192.168.1.87 in 6460 ms
GOT IP]
[]
[---Sending data---
CustomHTTPDest::process
CustomHTTP : 37ms
SerialDumpDest::process
IP    : 0.0.0.0
CHIPID    : 115E5D
RUNTIME    : 1
GMTTIME    : 44280001
RSSI    : -62
SerialDump : 123ms
MQTTDest::process]
[MQTT : 76ms
RFDest::process
RFX10 : 1ms
Blynk : 0ms
wss_start


WebSockets Server started on wss://192.168.1.87:8266
Open http://config.vair-monitor.com to configure device online
ready >
fupd]
[fg: 20161217, fc: 0, bn:20170122
ready >]
[---Sending data---
CustomHTTPDest::process
CustomHTTP : 38ms
SerialDumpDest::process
IP    : 192.168.1.87
CHIPID    : 115E5D
RUNTIME    : 129
GMTTIME    : 44400269
RSSI    : -60
SerialDump : 131ms
MQTTDest::process]
[MQTT : 77ms
RFDest::process
RFX10 : 0ms
Blynk : 0ms]
[---Sending data---
CustomHTTPDest::process
CustomHTTP : 41ms
SerialDumpDest::process
IP    : 192.168.1.87
CHIPID    : 115E5D
RUNTIME    : 250
GMTTIME    : 44520544
RSSI    : -62
SerialDump : 131ms
MQTTDest::process]
[MQTT : 78ms
RFDest::process
RFX10 : 1ms
Blynk : 0ms]
[Switched to power-safe mode. Press key during start or restart device to exit.
Completed in: 300427ms
Going into power-safe mode for 30 seconds]
[Ê$OPù¸ÿ]


How can I troubleshoot this situation? Any suggestion what to measure (pins on CM1106) to make sure it's HW or SW issue?


RE: v.Air - CO2 Monitor not recognised (CM1106) - vaanja - 01-28-2017

I was asking about firmware compatibility just because this sensor is older brother of your new products: http://shop.vair-monitor.com/index.php?rt=product/product&path=76&product_id=124 (CM1106 on Wemos D1 mini).


RE: v.Air - CO2 Monitor not recognised (CM1106) - admin - 02-01-2017

I was off for a couple of days.

So you say this is actually the older device that is not working - right ?

In general they should be compatible, but up to now i didn't test it too much.
it's firmware is here
http://anker-bg.com/vlast3k/vthing_co2/latest.bin
you can give it a try with it.
i will also check if this could be the reason


RE: v.Air - CO2 Monitor not recognised (CM1106) - vaanja - 02-01-2017

Thank you very much Vladimir.
Now it's working again. I was flashing this device with firmware dedicated to vesprino family.
So for those using CO2 Single Beam Sensor for Home Automation integration don't use vesprino firmware!
Also use version 5.2 of Chrome config utility to configure wifi/thingspeak etc. (vThings - Device Configuration Tool 8.7 not working for this device.)
Everything is clearly described here: http://vair-monitor.com/device-types/


RE: v.Air - CO2 Monitor not recognised (CM1106) - admin - 02-01-2017

Great Smile
In fact this is one of the next items on my roadmap, to make all of them use the same firmware.
in the last week i was reviving the original co2 monitor with display and leds Smile