Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
co2 monitor v3 /cdm7160 stops sending information/ jamming 433mhz rf devices
(02-24-2017, 07:19 PM)strichter76 Wrote: i am attaching full log.

I have discovered several problems, but the most critical one, for your case whas the fact that the Config tool was storing wrong URLs in case of Pimatic w/o password.
I am sure there are quite a few people from the pimatic community that bought the devices, but perhaps, they either used a password, or have been setting up this manually, (or simply do not use the device Smile    
I any case this is now fixed in the online configuration, and in the chrome app it will be pushed perhaps in a couple of hours
then you will need just to re-save your pimatic configuration and try it again

this is not related to the jamming though, for this i will make a firmware change once i verify some other stuff.
i just published the latest firmware update it fixes
1. configuration for PIMatic is now correct and does not use http://:@<host> in case there is no password - this was causing the random restarts
2. jamming should be fixed now, regardless of whether RF was enabled or not. it turned out when RF is disabled jamming is much more likely to occur, due to some floating HIGH value for the RF sending pin
I can confirm the jamming seems fixed with the new firmware, thanks alot!
(02-26-2017, 09:53 AM)vbs Wrote: I can confirm the jamming seems fixed with the new firmware, thanks alot!

ok, i am still on 20170103. and with enabled debugging and config-tool connected via usb it is runing now since my last post( 2 days ago).  so i assume no hardware / wiring problems with my unit.
yeah... just that - the problem with the jammings is that - right after start, the pin on the main board that is connected to sending RF433 is high... previously - the firmware was not doing anything, so eventually at some point of time it would go low as it's charge decreases
if RF is disabled - this will take some time
if RF is enabled - it will happen right after it tries to send data
in your case with the incorrectly generated Pimatic config from the config tool, the device was restarting before it can reach the RF part so it stays HIGH as long as it can
and the problem with the pimatic is apparently some race condition, as sometimes it works sometimes it doesnt
(when the http://:@<host> is used)
(02-26-2017, 09:53 AM)vbs Wrote: I can confirm the jamming seems fixed with the new firmware, thanks alot!

Sorry, I don't know why but jamming is happning again for me with "vESPrino v1.16 build20170226". Sad

After rebooting it is ok but as soon as I enter "nop 1" the jamming starts again. Just tested 3 times.

My device seems generally mad right now. When connecting I only get this ouput (usually there was a lot more):

Found WebSocketServer on:
WS Connected

vESPrino found on : WebSocket

Also settings are gone and when enabling RF again and pressing "Save RF config" then I get no output at all. Maybe I should do a factory reset or something...
I will check what happened to websocket connections
I was changing some stuff and maybe it affects this

You can revert back to the previous firmware with

And then go to Vesprino tab and set "go to sleep" time to 0
This should workaround the jamming as it apparently happens during sleep
can you try to enable the debug console in the browser, and see if there will be some error
i tried it a couple of times with firefox and chrome and it seems to be working
so it is apparently some race condition somewhere, or at least - seems to be harder to reproduce Sad
So, what can I do to help you debug this jamming problem?

I am still on the latest firmware and it is 100% reproducible for me when entering "nop 1". I activated Debug Mode before but there were no additional messages:
[Image: vair3.jpg]
hmm this is strange and i really hope there is a hardware issue Smile
(i already had a couple of boards with 1 pin shorted)
can you please try following
gpio_set D6 0
gpio_set D6 F
gpio_get D6

you should get at the end
gpio_get D6
GPIOBig Grin6 (12) :0
ready >]

if you get
GPIOBig Grin6 (12) :1

then the problem is hardware and i will send you a new main board right away
you can also then try to remove the whole addon board that connects to the main board
to verify that the command will still return 1

Forum Jump:

Users browsing this thread: 1 Guest(s)