Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Device configuration tool not showing output
I upgraded my monitor yesterday (see version below). It worked fine overnight but today I wanted to change the IP address of the MQTT broker and now I can't get the configuration tool to do anything useful.

Starting with the device unplugged:

1) Check there's no /dev/ttyUSB0.

2) Plug in. LED comes on bright blue and /dev/ttyUSB0 appears.

3) Start config utility.

4) It shows “Searching” then ”Not found”.

5) Press ”Not found”.

6) Blue LED blinks out very briefly then back on.

Output shows:

Searching for v.Air Trying : /dev/ttyUSB0

 .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . Searching for v.Air Trying : /dev/ttyUSB0

 .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

7) Close down the config utility but leave the monitor plugged into the USB port (LED on bright blue).

8) After a few minutes light goes out.

9) Start the config utility again, still can't connect though the blue LED comes back.

Earlier I did get it to connect (somehow, don't remember the sequence) but only got the following in the output box.

Searching for v.Air Trying : /dev/ttyUSB0

[vESPrino v1.16 build20170122]

vESPrino found on : /dev/ttyUSB0

Sending the ”factory” command and so on caused effects like making the LED flash green and causing the WiFi access point to appear but didn't give any echoed output as before in the output box.
can you try reflashing it via usb, as described here
maybe it is a coincidence and for some reason something in the firmware broke
when it is blue, is there some hotspot to connect to ?
and can you try to open the online config on
Yes, reflashing seems to have fixed it. It's working fine now. Ta.
Great Smile i notice this from time to time
my previous design was not allowing to easily reflash the wifi module and people had to send the devices back to me to reflash them... then i decided to never again do it like this Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)