Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CDM7160 - Recovery procedure
Hi together,

since yesterday morning one of my sensors does not respond any more. It does not send any data and even worth it's not recognized by the configuration tool any more. LED keeps off. The only thing what is monitored is as plugging into my laptop it recognizes the com port.

Before of that it ran with the firmware from 3rd of January 2017 and had the violet LED constant on. I performed some power cycles as before this recovered the situation and brought back normal operation usually but not this time.

I've tried also three different types of power supply (MPB, D-Link DUB-H4, a chinese brand USB supply) in combination with a normal and a pimped USB-cable (limiting the voltage).

What can I do, trying to recover the sensor? Is there any kind of procedure to low level rewrite the eprom potentially disconnecting parts of the sensor for troubleshooting?

Thanks in advance,
Hmm... this is strange.. you can try to reflash it as described here
in some cases the firmware tends to corrupt itself, but i do not know exactly when.

also - the wifi module may have failed for some reason... if you cannot flash it
you can try to open it and unplug the extension board from the main board
if it does not help
i will send you a replacement main board - already happened once that the mainboard failed for some reason
So I've performed some tests. The behavior is very weird for me.

As I reconnected the sensor today (after one day unpowered) the LED lid up violet and the sensor seems to operate normally. With the tool I could access the settings but as tried to flash the firmware (via the button) the LED did not change to red. Also on the „Send command“ line I tried otah did not change anything. No update within vAir Output window.

The communication seems having stopped again (refer to attached log).
I’ve performed a power cycle and the sensor just did nothing not even the violet LED illuminated.

I disconnected the boards inside the sensor which changed nothing also unfortunately.

At least each time it is connected, windows recognizes the connection of the new com port.

Trying again and reconnected the sensor again, the communication worked again via the tool. -> performing otah lit up the LED in red. But the tool reported:
"Will update from:
ledcolor red
ledbrg 80]
[HTTP error: connection refused]
(refer to attached file for complete log)

Than I tried also to flash via the command line tool, disconnected to tool before (refer to attached files).

The vAir Output within the tool
The output of esptool during trying to flash
The output of esptool during trying to erase

Finally yesterday I managed to activate the debugging mode but shortly after that the sensor stopped communication and operation again. Keeping the sensor powered it seems not having recovered during night.

So my current assumption is that communication via USB is not reliable (sometimes able to communicate, sometimes not), current status is: not able to communicate. Additionally the sensor operation is not reliable also, current status is: no operation. 
As my other sensor is working well with the firmware from 3rd of Jan., I do not have in mind a firmware issue currently.

I’ll try to take some logs today in the evening with debug enabled.  Also I’ve the impression that the behavior could be due to temperature (locally) and will try to detail this with ice spray as yesterday after a day unpowered first it operated normally.

Any other ideas to flash the eprom or to reanimate the communication? 

Btw within the linked instruction for flashing from the command line, the link to the firmware redirects to an old firmware and you’ll need to copy paste the address, just in case you’d like to correct that. 

Before you send a new one maybe could you think about adding also the parts to limit the supply voltage for my sensors (4) and let me know the additional costs for these parts?

I'll continue troubleshooting this evening.

Attached Files
.txt   vAir Output.txt (Size: 13.64 KB / Downloads: 1)
.txt   update-log.txt (Size: 3.43 KB / Downloads: 1)
.txt   erase-log.txt (Size: 3.37 KB / Downloads: 1)
Thanks for the analyze, and sorry you had to spend so much time with it.

It really looks like a hardware failure. It would be great if you could send just the main board, w/o all the sensors and so to me back.
Vladimir Savchenko
bul. Tzar Boris 3, 136 A
1618 Sofia

and i will refund you the postage fee. I want to see what exactly happened to this one so that i know for the future.

I will send you tomorrow a new one + the parts
So what I did yesterday:
I took it from the fridge (about 6°C) and connected to USB. It had been recognized directly by the tool.

I managed to flash the eprom first via the tool and repeated to flash than again via esptool right away.
Attached is the vAir Output log. After flashing also to Output seems to contain less or non crypted letters. 
Setting Wifi, MQTT and some other stuff, than if failed again. And now also supported by ice spray I did not manage to recover operation again. Also this morning it did not start again and seems to fail completely.

I share your assumption it is an hardware issue. I'll deinstall the mainboard and send it back to you tomorrow. Don't care for the shipment. Thanks a lot for your support, really! I would be interested in the results of your analysis at the end.

Some proposals for improvement:
- Maybe helpful  would be adding a timestamp (if available) to the line of the vAIR output maybe only in debug mode.
- You may add a hint to disconnect the chrome tool if trying to flash the eprom via esptool.exe. Otherwise the interface is used and blocked by the chrome tool. Furthermore remove the hyperlink to the old firmware from the post. Additionally  I did not manage to identify the device connected to a MBP but this is OT.

Attached Files
.txt   final-log.txt (Size: 73.14 KB / Downloads: 0)

Forum Jump:

Users browsing this thread: 1 Guest(s)