Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Randomly stop broadcasting (vESPrino v1.16 build20170228)
1. > i am not familliar with PM2 for running nodejs scripts.
The script listens by default on port 8080
see "const PORT=8080"
maybe if in your RPI something is already listening on this port - the http server cannot bind to it and this is why it fails
Also in the vESPrinom you need to configure the destination with the correct port (and i had forgotten - just make sure that it ends with some path, e.g., w/o /xxx it seems to not work)

2.) i believe you would need to change also the "idx" parameter, to another one, so that it does not get overridden

3.) nooo.. i would rather expect that once it stops working after N hours, you would check what colors the led shows (e.g. wait 2 minutes, until the next iteration begins), or see if it is still logging on the logging destination (and then what would it dump), or if the Runtime value is sent, but the CO2 not

4.) to make the led more visible, go again to ConfigTool/vESPrino and there in "Brightness Override" choose e.g. 20. I will change the colors to be e.g. White, Blue, Orange in the evenening

And finally, you can still downgrade to some of the previous firmwares, as described here

This way it will be clarified if it is indeed a software or a hardware issue

Messages In This Thread
RE: Randomly stop broadcasting (vESPrino v1.16 build20170228) - by admin - 03-27-2017, 10:55 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)